Elevated Authentication Errors

Incident Report for STEAMe

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:36 CDT

Investigating

Our authentication provider is currently experiencing availability issues. STEAMe users may have intermittent issues logging in.
Posted Oct 20, 2025 - 15:18 CDT
This incident affected: STEAMe Application (app.steame.com).